> For the complete documentation index, see [llms.txt](https://docs.shadersource.io/llms.txt). Markdown versions of documentation pages are available by appending `.md` to page URLs; this page is available as [Markdown](https://docs.shadersource.io/assets-and-plugins/landscape-material-tool/changelog/changelog-v2.0.md).

# Changelog v2.0

\[23 December 2024] Version 2.0 - UE5.4+

{% hint style="info" %}
See the [documentation for the Landscape Tool 2.0+](/assets-and-plugins/landscape-material-tool/how-to-use-5.4+.md) for more information.
{% endhint %}

### Bug Fixes

* \[Bug Fix] Fixed bug where tool did not take into account Source Control locks before trying to save assets.
* \[Bug Fix] Deleting a Material or Layer from the Content Browser while it's open in the Landscape Material Tool Editor Mode will crash the editor.
* \[Bug Fix] Reverting a Material or Layer in Source Control while the asset is open in the Landscape Material Tool Editor Mode will crash the editor.
* \[Bug Fix] Fixed an issue where very occasionally the editor might crash on closing when the Landscape Material Tool Editor Mode is active.
* \[Bug Fix] Fixed a crash when clicking Reload Level in an Untitled/Unsaved map.
  * Reload Level will also prompt to save an Untitled/Unsaved map as an asset.
  * Reload Level will show a warning if the level can't be reloaded.

### General

* Massive cleanup, rework, and optimisation of code.
* Renamed categories to remove redundant descriptor 'Landscape'.
* Added Editor Notifications for many actions.
* Renamed classes, structs, enums, namespaces, and related files with new Shadersource naming convention.
* Updated icons from UE4-style icons to UE5-style icons.
* Added settings to change defaults in Project Settings.
* Added prompts to save previous Material/Layer if dirty when Material/Layer references are changed and when exiting the Editor Mode.
* Updated Copyright Notice.
* Rewrote all [documentation to be better and reflect the new version of the Landscape Material Tool](/assets-and-plugins/landscape-material-tool/how-to-use-5.4+.md).
  * This includes a [Quick Tutorial](/assets-and-plugins/landscape-material-tool/how-to-use-5.4+/quick-tutorial.md).
* Fixed numerous spelling and grammar mistakes throughout the code.

### Editor Mode Header

* Added SHADERSOURCE Header to the Editor Mode.
  * Added tool name.
  * Added SHADERSOURCE branding.
  * Added Quick Select of SHADERSOURCE Editor Modes to easily switch between.
  * Added Documentation button.
  * Added Store Page button.
* Added the tab and action buttons to the Editor Mode header so that action buttons don't disappear when scrolling down in the tool.
* Added shortcut button to header to open the [SHADERSOURCE Texture Tools](/assets-and-plugins/texture-tools.md) if the plugin is enabled/loaded, or open its Fab page if it is not.

### Landscape Interaction

* When the Master Material or Material Instance is manually set, it now updates the material on the selected landscape too (optional).
  * Updating the Landscape Material through the normal Details Panel for the Landscape Actor now automatically updates the Editor Mode panel.
* Landscape Reference now works combined with Viewport selection: Selecting a Landscape (or Landscape Streaming Proxy) in the Level Editor Viewport will update the Landscape Reference in the Editor Mode, and manually selecting a Landscape from the dropdown will select the Landscape in the Level Editor Viewport.
* Added support for Landscape Streaming Proxies.

### Tools Tab

* Removed the Tools tab (relocated everything to other areas of the Editor Mode).
  * Removed Gather Materials Button completely - this now happens automatically when the Landscape Actor Reference changes (optional).
  * Landscape Reference is now in Editor Mode header.
  * Reload Level button is now in Editor Mode header.
* Removed Live Link option.
* Added a new Instance tab.
  * Moved Material Instance Reference to the Instance Tab.
  * Added Material Instance Parameters to the Instance Tab.
  * Added tooltip to show Material Instance stats when hovering the Material Instance.

### Layer Tab

* Most of the Layer Material Function backend has been reworked and remade.
* Added Ability to disable specific texture maps if they are not used (this is reflected in the code which saves shader instruction calls)
* Complete Overhaul of Triplanar Mapping / World Aligned Textures with new Advanced Triplanar mapping options.
* Removed Texture Variation for new Swizzle and Blotch based tiling.
* Added Ability to blur Heightmaps.
* Overhauled the Global Distance Swap.
  * Ability to use the detail textures for Global Distance Swap.
  * Ability to toggle on the full Global Parameter set
* Variable "Paint Over Previous" has been renamed to "Noise Layer" with its description updated to better reflect its functionality.
  * Also moved to the Layers context menu.
* Moved New, Reset, Apply, Create Copy, Copy Layer Data to the Layer selection in the header.
  * "Revert" is now "Reset" to more accurately reflect functionality.
  * "Save" is now "Apply" to more accurately reflect functionality.
  * "Save As" is now "Create Copy" to more accurately reflect functionality.
  * "Gather" is now "Copy Layer Data" to more accurately reflect functionality.
* Added ability to select Layer to Edit from the Master Material in Layers Tab context menu.
* Added '\*' to display when the Layer is dirty/unsaved.
* Added new tooltip with extra information about the selected Layer:
  * Content Browser Path
  * Materials referencing this Layer
  * Layer details in the selected Master Material.
* Overlay category is now called Overlay Blend Parameters and are hidden if the current layer is not an overlay or cliff blend in the Master Material.
* Cliff category is now called Cliff Blend Parameters and are hidden if the current layer is not a cliff blend in the Master Material.
* Added Undo to Reset and Copy Layer Data buttons.
* Added confirmation popups for Reset Layer and Copy Layer Data buttons.
* Copy Layer Data no longer reads from the selected asset in the Content Browser, instead it now has its own context menu for selecting a Layer to copy the data from.
* Falloff Texture, Falloff Texture UV Scale, and Falloff Texture Channel are now disabled when Falloff Use Height Map is unticked.
* Added ability to Rename a Landscape Layer.

### Material Tab

* Added ability to enable Fully Rough Material
* Moved the Master Material reference to the Editor Mode header so that it's visible in all tabs.
* Moved the Layers array into a new panel that displays them in order like Photoshop layers.
  * Simplified UI layout.
  * Filter added to Layers selection.
  * Added context menu with multiple new options:
    * Edit Layer: Open this Layer in the Layers tab
    * Shift Layer Up: Moves this layer up one in the hierarchy
    * Shift Layer Down: Move this layer down one in the hierarchy
    * Delete Layer: Deletes this layer from the Master Material
    * Insert Layer: Insert a new blank layer here
    * Layer Via Copy: Creates a new layer by duplicating this layer
    * Layer Via Copy & Replace: Creates a new layer by duplicating this layer and then replaces this layer with the new duplicated copy.
* Moved New, Save, Compile buttons to the Material selection in the header.
* Added '\*' to display when the Material is dirty/unsaved.
* Added Undo to Reset Master Material button.
* Grass Types and Physical Materials have updated UI.
* \[Experimental]: Added [Material Converter](/assets-and-plugins/landscape-material-tool/how-to-use-5.4+/landscape-material-tool-editor-mode/material-tab/convertible-material.md) to convert other Landscape Materials into Materials that work with the Landscape Material Tool.

### Example Content

* Recreated all new Example Content to better reflect the new Landscape Material Tool update.

{% hint style="info" %}
See the [documentation for the Landscape Tool 2.0+](/assets-and-plugins/landscape-material-tool/how-to-use-5.4+.md) for more information.
{% endhint %}
